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2011 IMAPP Training Workshop: Satellite Direct Broadcast for Real-Time Environmental 
Applications 

 
Lab 3  -  MODIS Applications 

Kathleen Strabala         3 June 2011    East China Normal University, Shanghai 
 
Case Study – Using MODIS DB data to detect nighttime low clouds and fog 
 
The costs to stranded passengers in terms of money and inconvenience [due to fog] may be 
impossible to calculate. In Canada, approximately 50 people per year die because of motor 
vehicle accidents (Gultepe et al. 2007a) in which fog was a contributing factor (Transport 
Canada Report 2001).  A study from 2010 found an increasing number of traffic accidents 
caused by fog reported in China in recent years.  Their results show that the frequencies of fog 
events in wintertime over eastern‐central China have doubled over the past three decades. (Niu, 
F., Z. Li, C. Li, K.‐H. Lee, and M. Wang (2010), Increase of wintertime fog in China: Potential 
impacts of weakening of the Eastern Asian monsoon circulation and increasing aerosol loading, 
J. Geophys. Res., 115) 
 
1a). Load the Aqua MODIS image from 17:55 UTC, 21 February 2011 (a1.11052.1755.1000.hdf) into 
Hydra and open the Multi-Channel Viewer as shown in Figure 1.   
 

 
Figure 1.  Aqua MODIS scene from 21 February 2011, 17:55 UTC, as displayed in Hydra. 
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b).  Is this a day or a night granule?  How do you know this? 
 
c). Look at the data in the Infrared bands (20-36).  Where do you think there are clouds in this data set?  
Why? 
 
d). Change the band in the Multi-Channel Viewer to band 31. Now open a new Multi-Channel Viewer 
(Start->Multi-Channel Viewer) and load band 20 (3.80 µm).  From the band 31 window, open the 
Transect window (Tools->Transect), and draw a transect over the band 31 (11.0 µm) image as shown 
in Figure 2.  From the band 20 Multi-Channel Viewer window, select Tools->Transect.  The band 20 
(3.80 µm) brightness temperature will appear in the same transect window as displayed in Figure 2. 
 

 
Figure 2.  Transect showing brightness temperatures along a line from North Central China to 
Shanghai to the coastal waters from Aqua MODIS band 31 (11.0 µm) and band 20 (3.80 µm). 
 
e). Judging from the data, are these two bands affected by atmospheric absorption?  Why or why not?   
 
f).  Locate areas in the data where the brightness temperatures between the two bands are different.  
What image features correspond to the band 31 (11.0 µm) brightness temperatures that are greater than 
band 20 (3.80 µm)?  What image features correspond to the band 20 (3.80 µm) brightness temperatures 
that are greater than band 31 (11.0 µm)?  Why would differences exist between these two window 
channels?  When you are finished, close the transect window, and the band 20 (3.80 µm) Multi-
Channel Viewer window. 
 
g).  Select the small region over Shanghai to examine at high resolution as shown in Figure 3. 
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Figure 3. 1 km resolution data displayed in the Multi-Channel Viewer window for the examination of  
fog and low cloud detection capabilities of the MODIS instrument. 
 
h).  Open the Linear Combinations window (Tools->Linear Combinations) and create a  
brightness temperature difference image of band 20 (3.80 µm) – band 31 (11.0 µm).  Change the color 
scale to Gray (Settings->set color scale->Gray).  What is the range of values in the image? 
 
i).  Create a single and image of band 31 (11.0 µm) brightness temperatures.  Now create a scatter 
diagram of [band 20 (3.8 µm) – band 31 (11.0 µm)] versus band 31 (11 µm) by selecting the XAxis 
button on the band 31 image and the YAxis button on the band 20 – band 31 image.  Once you have 
done this, the Scatter button becomes active in the Linear Combinations Tool window and you should 
click on it.  A new window will appear containing the scatter diagram.  
 
j). Examine the scatter diagram closely. Enlarge the window and magnify different regions so that you 
can see the patterns.  Map the different patterns of the diagram to where they are located in the X and 
Y images by selecting Box or Curve buttons in the scatter diagram and then outlining a region (See 
Figure 4).  You can map more than one region by choosing a different color from the selection at the 
bottom of the window.  You can turn the mask off and on using the toggle button (Mask is On) at the 
right hand side of the [band 20 (3.8 µm) – band 31 (11.0 µm)] and band 31 (11.0 µm) image windows. 
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Figure 4. Scatter diagram (right panel) of MODIS band 31 - band 20 (left panel) and band 31 (middle 
panel) brightness temperatures from 21 February 2011. 
 
k).  Radiation fog forms by the cooling of land after sunset by thermal radiation in calm conditions 
with clear sky. The cool ground produces condensation in the nearby air by heat conduction. In perfect 
calm the fog layer can be less than a meter deep.  Advection fog is caused by warm air moving over 
cool land.  In a paper published in February, 2011, (Chaurasia, S., Sathiyamoorthy, V., Paul Shukla, 
B., Simon, B., Joshi, P. C. and Pal, P. K. (2011), Night time fog detection using MODIS data over 
Northern India. Meteorological Applications, 18: n/a.doi: 10.1002/met.248), they found a relationship 
between the optical depth, the size of the water drops and the brightness temperature differences.  
Using this relationship, shown in Figures 5 and 6, what parts of the cloud have the smallest droplet 
sizes and the highest optical thickness?  Why is this important to know? 

 
Figure 5. Simulation of the variation of MODIS brightness temperature differences, band 20 (3.80 µm) 
minus band 31 (11.0 µm), with fog droplet size from Chaurasia et al, 2011. 
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Figure 6.  Simulation of the variation of MODIS brightness temperature differences, band 20 (3.80 
µm) minus band 31 (11.0 µm), with optical depth from Chaurasia et al, 2011. 
 
l). What band 20 (3.8 µm) – band 31 (11.0 µm) brightness temperature difference threshold would you 
use to identify regions of low cloud/fog?  
 
m).  What are the advantages and disadvantages of using the polar orbiter data and geostationary  
satellite data for low cloud/fog detection.  How do they complement each other? 
 
n).  Would this technique work if applied during the day? 
 
o).  Based upon what you have seen in this data set, what would you tell transportation authorities 
about the potential for low visibilities and cloud ceilings because of this data?  How could the 
presentation of this information be improved?  Open the kml file from the data directory 
(FOG_PRODUCT_CHINA_MODIS_21_FEB_2011_1755.kml).  This should launch the same 
brightness temperature difference image in the Google Earth Geobrowser.  The temperature 
differences less than -1 K are enhanced with a yellow to red color scale (red is -6 K).  What roads 
around Shanghai would you want to warn authorities about the possibility of low visibilities?  What 
parts of the cloud would you expect to take longer to dissipate after sunrise?   
 
Exercise 2 – Case Study – Strong Low Pressure System and Dust Storm of 11 May 2011 
 
This exercise will use products generated from the ECNU MODIS processing system to examine 
a strong low pressure system.  It is intended to provide guidance on using DBCRAS in McIDAS-
V as well as IDEA-I processing to help forecast the movement of the storm and its affect on 
weather and air quality 
 
The Direct Broadcast CIMSS Regional Assimilation System (DBCRAS) NWP uses MODIS direct 
broadcast cloud and water vapor products (MOD06 and MOD07) to improve the depiction of cloud 
and moisture in the model. The model output is 72 hour forecasts at 3 hour intervals of standard 
meteorological products including temperature, moisture (dewpoint, humidity), winds (speed and 
direction) and precipitation. Unique to DBCRAS, is output forecast satellite imagery that includes 6.7 
micron (water vapor) and 11 micron (window channel) brightness temperatures. This exercise will give 
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the user an introduction into how this model could be useful in assisting in the prediction of 
environmental hazards.  
 
2a). Start McIDAS-V by clicking on the V icon on your desktop. McIDAS-V is freely distributed 
software ( http://www.ssec.wisc.edu/mcidas/software/v/download.html ) that can quickly load and 
animate the native grib2 DBCRAS output files. Once you start up McV, 3 windows will open. A 
McIDAS-V Help Tips window. a Main window with Map Display and a Data Explorer Window.  
Load in an output DBCRAS model run file from 00 UTC, 11 May 2011, by going to the Data Explorer 
window, and selecting General -> Files/Directories from the left set of choices. Select the grib2 file 
11May11.00z.dbCRAS.grib2 from the directory tree, and then choose Add Source at the bottom of the 
window. A new window should open with 3D grid and 2D grid listed under Fields. These are all of the 
fields that can be displayed from the DBCRAS output file. Expand the 2D grid selection by clicking on 
the circle next to it, and then do the same for the Short_wave_Radiation header. Select  
 
Brightness temperature @ cloud_tops  
 
This will cause a list to appear on the right under Displays. Select Color-Shaded Plan View under 
Plan Views, and then choose the Create Display button at the bottom. Once you do this, an image 
should appear in the Map Display (see Figure 7). Choose the play button at the top of the display to 
show the whole 25 image loop. You have displayed a 3 day forecast of 11 micron brightness 
temperatures. You can zoom in on the display by using Shift+right mouse scroll or Shift+left mouse 
where you can outline a region of interest. You can go back to the original display by clicking on the 
house icon in the left navigation bar. Change the enhancement on the image by going back to the Data 
Explorer window Layer Controls tab, and clicking on the Color Table: default button and follow the 
dropdown to ->System->Inverse Gray shade. You can make the gray shades smoother by choosing the 
Shade Colors box in the Data Explorer->Layer Controls tab. Describe some basic information that 
can be acquired through the animation. From what direction are the clouds moving toward Shanghai 
through this time period. Are their any interesting features (any spinning clouds). Where are the 
coldest clouds? How can you tell when the forecast time is day or night from the loop? 

 
Figure 7.  Screen capture of a McIDAS-V display of DBCRAS forecast 11 micron brightness 
temperatures from 00 UTC, 11 May 2011. 
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b). Now overlay the forecast precipitation into the loop. Do this by going back to the Data Explorer-
>Field Selector tab and choosing Moisture->Total precipitation@surface. Choose Color-Filled 
Contour Plan View under Displays and then Create Display. In the Map Display, you should see the 
precipitation fields overlaid on the forecast satellite imagery.  You will need to start the loop because 
there is no precipitation field during the 00 hour forecast. Is there a relationship between precipitation 
and the coldest cloud tops?  How would precipitation affect aerosols? 
 
c). Now overlay the pressure reduced to mean sea level. From the Data Explorer->Field Selector tab, 
choose Mass->Pressure reduced to MSL@msl and then Contour Plan View from under Plan Views 
under Displays. After choosing this, select Create Display. How many low pressure systems are there 
over China during this 72 hour time period? What is the lowest pressure that you can find (you can 
hold down the middle mouse button while you move the cursor to see the values that are displayed in 
the Panel at the bottom)?  Why is low pressure associate with clouds?  There are many fields at all 
vertical levels that can be plotted in this data set. 
 
d). Now add forecast wind fields to the display. Under the Field Selector tab->3D grid->Momentum-
>Derived->Flow Vectors (from U-component_of_wind & V-component_of_wind) and then under 
Displays choose Wind Barb Plan View and Create Display. The screen should be filled with wind 
barbs. Under Layer Crontrols->Skip: XY change the value from 0 to 5 to declutter the image. This will 
then display the wind for every 5th grid point. Wind barbs show the direction and speed of the wind 
where one wind flag=50 knots (1 knot = .51 m/s), one barb = 10 knots and one half barb = 5 knots. The 
direction of the wind flag shows the direction that the wind is coming from. Is there a relationship 
between winds and pressure? Save the Display as an animated gif. From the Map Display – Panel 1, to 
the left of the loop controls in the main display window, select View->Capture->Movie. A Movie 
Capture window will appear, where you can save individual frames or the entire animation. Select the 
Time Animation button. When you click on this button, McIDAS-V will start saving each image in the 
loop. This will take a few seconds. When it is finished loading them into memory, a new Save window 
will pop up. Name your animation and save it as an animated gif (File Format: Animated GIF). Start 
up Power Point and copy and display the animation.  
 
d). Delete some of the displays that you have created so far by clicking on the trash can icons in the 
Display window under Legends next to the 2 Plan Views of Pressure and Precipitation and the Flow 
Display wind barbs. This should leave the display showing only the forecast satellite data.  
 
e). Now we will create a time series of values for a given point. From the Data Explorer choose 2D-
>Temperature->Temperature@height_above_ground, then from under Displays, select Data 
Probe/Time Series followed by Create Display. A 72 hour time series plot of temperatures will display 
in the Data Explorer window for the location shown by the red box in the Map Display. You can 
change the location of the display around by left clicking on the box and dragging the point around. 
Notice how the values change as you move. Now add moisture, precipitation and winds to the time 
series by selecting Edit->Add Parameter in the data explorer window. A new Field Selector window 
will open for you to choose from. Select Moisture->Total preciptaion @ surface and then OK. Next 
add relative humidity to the diagram by choosing 2D grid->Moisture->Relative 
humidity@planetary_boundary and OK. Finally, add wind fields to the time series (3D grid-
>Momentum->U-component of wind@pressure, then select Level->100000Pa then Add Selected>>. 
Then do the same for the V-componenet of the wind). Once you have finished, click on OK at the 
bottom of the window. Look at your display. It should look like the screen capture in Figure 8. Move 
the time series display to different locations in the land. How much precipitation falls on Shanghai? 
Can you tell when the cold front comes through?  
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Figure 8.  Screen capture of McIDAS-V display of a DBCRAS forecast grib2 time series from  
00UTC, 11 May 2011.  
 
f). Describe how this NWP model might help you in your work. For example, the forecast wind and 
precipitation fields can help in determining aerosol transport. The forecast satellite imagery conveys 
information about the atmosphere in 3 dimensions, providing information that would have to be 
interpreted from static maps at individual levels.  
 
g). Now open the local html file from your browser that will display the IDEA-I forecast images from 
this day (IDEA-I_May11_2011.html ) .  It uses a free simple flash based program called FlaniS ( 
http://www.ssec.wisc.edu/flanis/ ) to allow users to control individual image files in the form of 
animations. When you open this file, you can control the animation using the controls at the top, as 
well as zoom in the region by left click, or zoom out by Alt+left click.   The background of the image 
is the MODIS aerosol optical depth from Terra.  The forecast is out through 12 May at 23 UTC.  
Where are the aerosol optical depths the largest?  Winds are also plotted in this image in the form of 
vectors, which provide the direction the wind is coming from, and the strength of the wind by the 
length of the arrow shaft.  Where are the winds the strongest?   
 
h).  As you examine the animation in html, compare it to the DBCRAS model output. When are the 
aerosols forecast to arrive in Shanghai?  Approximately what level are the aerosols forecast to be in 
Shanghai? How will this affect humans at the surface?  Look at the time series that you created for 
Shanghai.  What happens at the time that the aerosols arrive in Shanghai to the humidity, the 
temperature and the wind?  Is there any precipitation?  How can precipitation change the effects of 
pollution to make them better or worse? 
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i). Now look at the meteogram from Shanghai from 12 May 2011 (Figure 9).  A meteorgram is a time 
series of meteorological parameters.  Compare the temperature, humidity and wind profiles for this day 
with the DBCRAS and IDEA-I outputs.  How accurate were IDEA-I and DBCRAS for this storm? 
 
 

 
Figure 9.  Meteogram of observations taken at Shanghai Pudong airport on 12 May 2011. 
 
Exercise 3 - Case study from 29-30 April 2011 
 
6a). Now that you know how to use these tools, use them to examine the dust storm case study from 
29-30 April 2011. Examine the large storm that develops in Mongolia and moves into China during 
this time, as if you were preparing to provide information to local officials about the storm hazards to 
people, animals and possessions.  Use the DBCRAS and IDEA-I forecasts to study in detail the 
preconditions of the storm, including the meteorological values prior to the advance of the low 
pressure system, the development of the storm and the impact of the storm.  Make a forecast based 
upon the DBCRAS NWP model run at 00 UTC 28 April and IDEA-I forecasts from 29 April 2011.  
When will the storm affect different parts of the country?  Where will the winds be the strongest?  
Where will the air quality be the worst?  Then validate your forecasts using meteograms for the 4 
locations shown in Figure 10.   
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Figure 10.  Locations of meteograms covering the dates of a large low pressure system and dust storm 
on 29-30 April 2011.  The locations are Beijing, China (ZBAA), Xi An, China (ZLXY), Ulan-Bator, 
Mongolia (ZMUB) and Shanghai, China (ZSPD).  
 
The 4 letter airport codes are from: 
 
ZBAA - Beijing, China  - Latitude 40.08  Longitude 116.584 
ZLXY - Xi An, China - Latitude 34.447  Longitude  108.751 
ZMUB - Ulan-Bator, Mongolia - Latitude  47.843  Longitude  106.766 
ZSPD - Shanghai, China - Latitude  31.1433   Longitude  121.805 
 
How well did DBCRAS and IDEA-I perform for this case study?  Where was it accurate and where 
was it inaccurate?  Compare the IDEA-I aerosol trajectory forecast for 29 May 2011 with the initial 
aerosol optical depth locations from 30 May 2011?  How could this be improved?  Why is this 
important?  Could you forecast a dust storm using just DBCRAS (without IDEA-I)?   
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Figure 11.  Weather Map Symbols used in meteograms. 
 
 


