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Table 1: MODIS Channel Number, Wavelength (μm), and Primary Application 

Reflective Bands      Emissive Bands 
1,2 0.645, 0.865  land/cld boundaries  20-23 3.750(2), 3.959, 4.050 sfc/cld temperature 
3,4 0.470, 0.555  land/cld properties  24,25 4.465, 4.515  atm temperature 
5-7 1.24, 1.64, 2.13 “     27,28 6.715, 7.325  water vapor 
8-10 0.415, 0.443, 0.490 ocean color/chlorophyll  29 8.55   sfc/cld temperature 
11-13 0.531, 0.565, 0.653 “    30 9.73   ozone 
14-16 0.681, 0.75, 0.865 “    31,32 11.03, 12.02  sfc/cld temperature 
17-19 0.905, 0.936, 0.940 atm water vapor   33-34 13.335, 13.635,   cld top properties  
26 1.375   cirrus clouds   35-36 13.935, 14.235  cld top properties 
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Figure 1: MODIS and SEVIRI bandwidths with reference spectra from a standard atmosphere. 

Figure 2:  MODIS (orange) and SEVIRI (green) Spectral Response Functions (SRF). 
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Exercise 1 – Using MODIS for nighttime fog detection 
 
1a).  Load the Terra MODIS image from 27 July 2005, 21:05 UTC, 
(MOD021KM.A2005208.2105.005.2009156230628.hdf) into HYDRA and open the Multi-Channel 
Viewer as shown in Figure 3. 
 

 
 
Figure 3: Terra MODIS scene from 27 July 2005, 21:05 UTC, as displayed in HYDRA. 
 
b).  Is this a day or a night granule?  How can you tell? 
 
c).  Display the data at full resolution by selecting a subset of the data displayed in the HYDRA 
window (right most icon in toolbar in the HYDRA main window).  The 1 km resolution data will 
appear in the Multi-Channel Viewer window.  Select a region covering the Northeast portion of the 
scene (see Figure 4). 
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Figure 4: 1 km resolution data displayed in the Multi-Channel Viewer window for the examination of 
the fog detection capabilities of MODIS data. 
 
d).  Look at this scene quickly in the Infrared bands (20-36).  Try to identify where the clouds are in 
the scene.   
 
e).  Start the Channel Combination Tool (Tools->Linear Combinations).   Compute a brightness 
temperature difference (BTDIF) image of band 20 (3.80 micron) – band 31 (11.0 micron). Describe 
your results. What is the range of data values over the scene?  
 
f). Create single band image of Band 31 (11.0 micron) by using the Channel Combination Tool.  
Choose one band in the first red box, then select the blank space for the mathematical operator, and 
then Compute.     
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g). Now create a scatter diagram of [band 20 (3.8 micron) – band 31 (11.0 micron)] versus band 31 (11 
micron) by selecting the XAxis button on the band 31 image and the YAxis button on the band 20 – 
band 31 image.  Once you have done this, the Scatter button becomes active in the Linear 
Combinations Tool window and you should click on it.  A new window will appear containing the 
scatter diagram. 
 



 
h). Examine the scatter diagram closely. Map the different patterns of the diagram to where they are 
located in the X and Y images by selecting Box or Curve buttons in the scatter diagram and then 
outlining a region (See Figure 5).  You can map more than one region by choosing a different color 
from the selection at the bottom of the window.  You can turn the mask off and on using the toggle 
button (Mask is On) at the right hand side of the [band 20 (3.8 micron) – band 31 (11.0 micron)] and 
band 31 (11.0 micron) image windows.   
 

 
 
Figure 5: Scatter diagram (right panel) of MODIS band 31 - band 20 (left panel) and band 31 (middle 
panel) brightness temperatures from 27 July 2005. 
 
i).  Identify the different regions in the scatter diagram.  There is a 30 C difference over this small area.  
Can you give some reasons for the difference in brightness temperatures between these two “window” 
regions (small amount of atmospheric absorption).   
 
j).  The purple region seen in Figure 5 outlines the low cloud/fog region.  Can you find a threshold that 
you could use to automatically identify regions of low cloud/fog. 
 
k).  What are the advantages and disadvantages of using the polar orbiter data and geostationary 
satellite data.  How do they complement each other?   
 
l).  Would this technique work if applied during the day? 
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Exercise 2 – Using MODIS to identify potentially severe thunderstorms 
 
2a). Load the Aqua MODIS data from 5 May 2009, 20:55 UTC into HYDRA 
(MOD021KM.A2009125.2055.005.2009126081635.hdf).  Start the Multi-Channel Viewer, and select 
a small portion of the scene as shown in Figure 8.  
 

 
 
Figure 8:  MODIS data from 5 May 2009 as displayed in HYDRA. 
 
b).  Using the pointer, click on warm portions of the scene (dark parts), and watch the brightness 
temperature pattern in the upper panel of the Multi-Channel Viewer.  Now select very cold portions of 
the scene.  Describe the differences in the patterns.  Can you explain why the temperatures are not 
always the same for every band in every Field-Of-View (FOV) in the image? 
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c).  Create a transect from a warm to a cold portion of the scene as shown in Figure 9 (Tools-
>Transect then shift+right click+drag).   Open up another Multi-Channel Viewer and display band 33 
(13.35 microns).  Choose Tools->Transect from this new Viewer.  A new line will appear in the 
transect overlaying the band 31 brightness temperatures along with the band 33 temperatures.  How do 
the temperatures compare?  Now change band 33 to band 34 (13.72 microns), then band 35 (13.91 
microns) and finally band 36 (14.20).  How do the temperatures compare as you go to longer and 
longer wavelengths?  What is the range of values in band 36 compared to band 31?  Why do the values 
differ?   How could this information be used to say something about clouds and the atmosphere? 
 



 
 
Figure 9:  Transect of band 31 (11 micron) brightness temperatures over a scene going from warm to 
very cold. 
 
d).  Overlay the MODIS Cloud Product that matches this time period (Load->Local Data 
MOD06_L2.A2009125.2055.005.2009128030024.hdf).  The Cloud Phase window will open, and the 
cloud phase product will overlay the image.  You can toggle it off and on.  Now overlay the cloud top 
pressure on the image (Variables->Cloud Top Pressure).  Why is this information important?  Now 
overlay the cloud top temperatures on the image (Variables->Cloud Top Temperatures).  How could 
the cloud top temperatures and cloud phase be used together to determine the potential for aircraft 
icing? 
 
e). Chose File->New to start a new HYDRA session.  Load the SEVIRI area that most closely matches 
the time of the MODIS overpass into this new HYDRA window (Load->AREA 
SEVIRI_2009125_2100.area).  Start a new Multi-Channel Viewer and chose a region in the SEVIRI 
that most closely matches the region selected in the MODIS image (See Figure 10).   
 
f).  Compare the range of temperatures across the scene using the 11 micron data (MODIS band 31, 
SEVIRI band 9).  Now set the range of data (Settings->Set Color Range) from 215.0 to 295.0 for both 
instruments in the Multi-Channel Viewers and set the color scale to color (Settings->Set Color Scale-
>color).  How do the temperatures compare.  Compare the detail in each instrument scene. 
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Figure 10:  MODIS and SEVIRI 11 micron imagery from ~21:00 UTC on 5 May 2009. 
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There are several signatures in the MODIS data that point to strong updrafts and the potential for 
severe weather such as hail, strong winds and heavy rain.  Although you need to gather a full suite of 
meteorological data to be more certain, including radar, surface and radiosonde information, there are 
features in this scene that have been shown to accompany severe weather.  Look closely at the tops of 
the very cold thunderstorms in the scene.  Zoom in on different clouds.  You will notice variations 
even in the cold tops and obvious points of coldest tops within the cells.  These are regions associated 
with strong updrafts (overshooting tops).  They are often times the strongest parts of the storm.  
Compare the appearance of these tops between MODIS and SEVIRI.  How could these instruments 
compliment each other in this case?  Now load MODIS band 27 (6.78 micron), and set the color scale 
back to Inverse Gray.  Can you see these cold “overshooting tops” in this image?  Note the wavy 
patterns to the east of some of these tops.  These are gravity waves that are initiated by the strong 
convection.  They are another indicator of strong storms.  Finally, strong updrafts are often associated 
with strong downdrafts.  They appear as dark (warmer) areas surrounding these cold cloud tops.  
Compare the detail of the water vapor bands to SEVIRI band 5 (6.20 micron).   
 
 
Exercise 3 – Using MODIS to estimate aerosol optical depth. 
 
3a). Load into hydra the local Aqua MODIS file from 20 August 2003 covering Southeastern Africa 
and Madagascar, MYD021KM.A2003232.1110.004.2004148203517.hdf.  Start the Multi-Channel 
Viewer, and then select the small region displayed in Figure 11. 
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Figure 11.  Main hydra window with a selection of the image from Aqua MODIS on 20 August 2003 
at 11:10 UTC (left) and high resolution band 3 (.45 μm) reflectance image in the Multi-Channel 
Viewer (right). 
 
Examine the scene in visible bands Band 1 (.68 μm), Band 3 (0.47 μm) and Band 7 (2.13 μm) and 
thermal bands Band 20 (3.80 μm), Band 21 (3.99 μm), and Band 31 (11 μm).   Note the range of 
values in the visible and IR bands.  What bands have the highest reflectances?  Which bands have the 
highest brightness temperatures? 
 
b.) Create an rgb of the full scene (Tools->rgb->Compute). Can you identify the aerosols in this 
image?   
 
c.) Open the Linear Combinations Window and create single images of Band 1 (.68 μm), Band 3 (0.47 
μm) and Band 7 (2.13 μm).  Change the color scale to gray and enhance the images.  Now create a 
scatter diagram of Band 3 (0.47 μm) on the X-axis and Band 7 (2.13 μm) on the Y-axis.   
 
d.) Examine the smoke plume by selecting regions of the plume in the image to see where the points lie 
on the scatter diagram.  In which band is the smoke signal stronger?   
 
 
e.) Now do the same for Band 1 (.68 μm) and Band 7 (2.13 μm).  How does this compare with the 
Band 3 (.47 μm) and Band 7 (2.13 μm) results? 
 
 
f.) The MODIS aerosol algorithm utilizes a look up table to get an initial estimate of the aerosol optical 
thickness τλ over land, based upon the measured reflectances and the surface reflectance.  This 
relationship can also be approximated by: 
 
           τ.68 ≈ (r.68 - .50*r2.1) 
           τ.47 ≈ (r.47 - .25*r2.1) 
 
 
What is the purpose of subtracting out the reflectances in Band 7 (2.13 μm)?  
 
g.) Now use the Channel Combinations Tool to create approximate τ.68 and τ.47 images.  Create an 
image of Band 1 (.68 μm) - .50 * Band 7 (2.13 μm).  Use the White box in front of the Green band 
selector to type in the constant.  Do the same for Band 3 (.47 μm) - .25 * Band 7 (2.13 μm).   
 
h.) How do the τ.68 and τ.47  values compare?  What are some causes for the differences?  
 
 
 
 
 
 
 
 
 



Exercise 4 – Using MODIS for determining cloud phase, atmospheric turbulence and areas of 
snow cover. 
 
a).  Load the 1 km Aqua MODIS file from 21 September 2008, 11:45 UTC 
(MYD021KM.A2008265.1145.005.2009167200228.hdf) into HYDRA.  Open up a Multi-Channel 
Viewer.   Select the region show in Figure 12 to view at full resolution. 
 

 
 
Figure 12:  Aqua MODIS image of band 31 (11 micron) brightness temperatures from 21 September 
2008, 11:45 UTC. 
 
b).  Identify the ice and the water clouds in the image.  Use the reflectances in bands 1 (.65 microns) 
and band 7 (2.13 microns) and the brightness temperatures in the window channels band 20 (3.80 
microns) and band 31 (11 microns).  Remember in band 7 (2.13 microns) ice and ice cloud absorb 
radiation, and in band 20 (3.8 micron) during the day, the brightness temperatures are contaminated by 
the inclusion of some solar reflection by water clouds.   Why is this information important?  Overlay 
the MODIS cloud product on this scene (Load->Local Data-
>MYD06_L2.A2008265.1145.005.2008266091110.hdf).  How does the cloud phase product compare 
with your observations? 
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c).  Now change to band 27 (6.78 microns).  Can you see the water cloud in this image?  There is a 
strong trough (dark curve) that can be seen in this band.  The dark and light patterns represent a 
topography in that the dark areas are warmer, representing a layer lower in the atmosphere, and the 
bright areas with more moisture representing a layer higher in the atmosphere.  Areas of strong 
gradients often times represent jet stream rising and sinking ageostrophic motion patterns.  These 
patterns are sometimes correlated with atmospheric turbulence, and the strength of the gradient.  Draw 



a transect through some of the strongest brightness temperature gradients in band 27 (6.78 microns).  
How large are the gradients? Now draw a transect across the wavy pattern seen along the coast. What 
kind of brightness temperature differences do you see in the waves?  Based upon your observations, 
where would you expect the strongest atmospheric turbulence to be?   
 
d).  Look at the Skew-T thermodynamic diagram from a ballon sounding launched from Durban (along 
the coast in the image) at 10 UTC in Figure 13.  This gives a vertical depiction of the atmosphere from 
this location at this time.  The red line is the temperature profile, the blue line is the dewpoint vertical 
temperature.  Pressure levels are giving along the Y axis on the left and in kilo-feet in blue on the right.  
Wind barbs showing the direction and speed of the wind at each level is provided in red.  One wind 
flag=50 knots (1 knot = .51 m/s), one barb = 10 knots and one half barb = 5 knots.  What is the 
approximate level of the jet stream in this image.  If the strongest turbulence is often reported just 
below this level, what height would you expect the maximum atmosphere turbulence to be located? 
 

 
 
Figure 13:  Vertical profile of the temperature, moisture and wind speed as determined from a balloon 
sounding from Durban, South Africa, 21 September 2008, 10 UTC. 
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e).  Now close HYDRA and restart.  Load in the Aqua MODIS 500 m file from this same time period 
(MYD02HKM.A2008265.1145.005.2009167200228.hdf).   Open a Multi-Channel Viewer and select a 
small region as shown in Figure 14. 



 

 
 
Figure 14:  Screen capture of the HYDRA display of a 500m Aqua scene from 21 September 2008. 
 
f).  Examine the reflectances in band 1 (.65 microns) and band 7 (2.13 microns).  Given what you 
learned by looking at the 1 km visible and thermal bands, what might you guess is the very dark region 
over land in the band 7 data?   
 
g).  Compute the Normalized Difference Snow Index (NDSI) using the Linear Combination Tool.  
The equation is [band 4 (.56 microns) – band 7 (2.13 microns)  / band 4 (.56 microns) + band 7 (2.13 
microns)].  What threshold would you use to define snow/no snow (set the color scale to Color, and 
then use Settings->Set Color Range to choose your threshold)?   Are there any places that this 
technique might fail? 
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Exercise 5  - Introduction to DBCRAS - Numerical Weather Prediction (NWP) using McIDAS-V 
 
The Direct Broadcast CIMSS Regional Assimilation System (DBCRAS) NWP model is freely 
distributed software, globally configurable and uses MODIS direct broadcast cloud and water vapor 
products (MOD06 and MOD07) to improve the depiction of cloud and moisture in the model.  To 
download the model, go to this web page: http://cimss.ssec.wisc.edu/imapp/dbcras_v1.0.shtml.  The 
output is 72 hour forecasts at 3 hour intervals of standard meteorological products including 
temperature, moisture (dewpoint, humidity), winds (speed and direction) and precipitation.  Unique to 
DBCRAS, is output forecast satellite imagery that includes 6.7 micron (water vapor) and 11 micron 
(window channel) brightness temperatures.   This exercise will give the user an introduction into how 
this model could be useful in assisting in the prediction of environmental hazards. 
 
5a). Start McIDAS-V by clicking on the V icon on your desktop.  McIDAS-V is freely distributed 
software (http://www.ssec.wisc.edu/mcidas/software/v/version-1.0beta1.html) that can quickly load 
and animate the native grib2 DBCRAS output files.  Once you start up McV, 3 windows will open.   
 A McIDAS-V Help Tips window, a Data Explorer Window and a Main window with Map Display.  
Load in an output DBCRAS model run file from 00 UTC, 26 July 2007, by going to the Data Explorer 
window, selecting General -> Files/Directories from the left set of choices.  Select the grib2 file 
26Jul07.00z.dbCRAS.grib2 from the directory tree, and then choose Add Source at the bottom of the 
window.  A new window should open with 3D grid and 2D grid listed under Fields.  These are all of 
the fields that can be displayed from the DBCRAS output file. Expand the 2D grid selection by 
clicking on the arrow next too it, and then do the same for the Short_wave_Radiation header.    Select  
 
 Brightness temperature @ cloud_tops 
  
This will cause a list to appear on the right under Displays.  Select Color-Shaded Plan View under 
Plan Views, and then choose the Create Display button at the bottom.  Once you do this, an image 
should appear in the Map Display (see Figure 15).  Choose the play button at the top of the display to 
show the whole 25 image loop.  You have displayed a 3 day forecast of 11 micron brightness 
temperatures.  You can zoom in on the display by using Shift+right mouse scroll or Shift+left mouse 
where you can outline a region of interest.  You can go back to the original display by clicking on the 
house icon in the left navigation bar.  Change the enhancement on the image by going back to the Data 
Explorer window Layer Controls tab, and clicking on the Color Table:  default button and follow the 
dropdown to ->Basic->Inverse Gray shade.   You can make the gray shades smoother by choosing the 
Shade Colors box in the Data Explorer->Layer Controls tab.   Describe some basic information that 
can be acquired through the animation.  From what direction are the clouds coming from through this 
period.  Does this imply warming or cooling through the 72 hours? Where are the coldest clouds?  
How can you tell when the forecast time is day or night from the loop?   

http://cimss.ssec.wisc.edu/imapp/dbcras_v1.0.shtml
http://www.ssec.wisc.edu/mcidas/software/v/version-1.0beta1.html


 
Figure 15.  Screen capture of a McIDAS-V display of DBCRAS forecast 11 micron brightness 
temperatures from 00 UTC, 26 July 2007. 
 
b).  Now overlay the forecast precipitation into the loop.  Do this by going back to the Data Explorer-
>Field Selector tab and choosing Moisture->Total precipitation@surface.  Choose Color-Filled 
Contour Plan View under Displays and then Create Display.   In the Map Display, you should see the 
precipitation fields overlaid on the forecast satellite imagery.  Is there a relationship between 
precipitation and the coldest cloud tops?  How many waves of precipitation affect the Cape Town 
region during this 72 hour period? 
 
c).  Now overlay the pressure reduced to mean sea level.  From the Data Explorer->Field Selector tab, 
choose Mass->Pressure reduced to MSL@msl and then Contour Plan View from the Plan Views 
under Display. After choosing this, select Create Display.  How many low pressure systems affect 
South Africa during this 72 hour time period?  Is there a relationship between the surface pressure, 
precipitation and 11 micron brightness temperatures?   There are many fields at all vertical levels that 
can be plotted.  
 
d).  Now add forecast wind fields to the display. Under the Field Selector tab->3D grid->Momentum-
>Derived->Flow Vectors (from U-component_of_wind & V-component_of_wind) and then under 
Displays choose Wind Barb Plan View and Create Display.   The screen should be filled with wind 
barbs.  Under Layer Crontrols->Skip:  XY change the value from 0 to 5 to declutter the image.  This 
will then display the wind for every 5th grid point. Wind barbs show the direction and speed of the 
wind where one wind flag=50 knots (1 knot = .51 m/s), one barb = 10 knots and one half barb = 5 
knots.  The direction of the wind flag shows the direction that the wind is coming from.  Is there a 
relationship between winds and pressure?  Can you see a relationship between wind speed/direction, 
orography and precipitation?  Save the Display as an animated gif.  From the Map Display – One 
Panel, to the left of the loop controls in the main display window, select View->Capture->Movie.  A 
Movie Capture window will appear, where you can save individual frames or the entire animation.  
Select the Time Animation button.  When you click on this button, McIDAS-V will start saving each 
image in the loop.  This will take a few seconds.  When it is finished loading them into memory, a new 
Save window will pop up.  Name your animation and save it as an animated gif (File Format: 
Animated GIF).  Start up Power Point and copy and display the animation. 
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d).  Delete some of the displays that you have created so far by clicking on the trash can icons in the 
Display window under Legends next to the 2 Plan Views of Pressure and Precipitation and the Flow 
Display wind barbs.  This should leave the display showing only the forecast satellite data.  Then right 
click on Memory: at the bottom of the Map Display Window, and choose Clear Memory & Cache.   
This will clean out the unused memory.    
 
e).  Now we will create a time series of values for a given point.  From the Data Explorer choose 2D-
>Temperature->Temperature@height_above_ground, then from under Displays, select Data 
Probe/Time Series followed by Create Display.   A 72 hour time series plot of temperatures will 
display in the Data Explorer window for the location shown by the blue box in the Map Display.   You 
can change the location of the display around by left clicking on the box and dragging the point 
around.  Notice how the values change as you move.  Now add moisture, precipitation and winds to the 
time series by selecting Edit->Add Parameter in the data explorer window. A new Field Selector 
window will open for you to choose from.  Select Moisture->Total preciptaion @ surface and then 
Add Selected>>.   Next add relative humidity to the diagram by choosing 2D grid->Moisture-
>Relative humidity@planetary_boundary and Add Selected>>.  Finally, add wind fields to the time 
series (3D grid->Momentum->U-component of wind@pressure, then select Level->100000Pa then 
Add Selected>>.  Then do the same for the U-componenet of the wind).  Once you have finished, click 
on OK at the bottom of the window.  Look at your display.  It should look like the screen capture in 
Figure 16.  Move the time series display to different locations in the land.  How much precipitation 
falls on Capetown.  Can you tell when the cold front comes through?  Move the cursor to the 
Johannesburg region. What time period would be most conducive for fires to begin or to continue?  
 
f).  Describe how this NWP model might help you in your work.  For example, the forecast wind and 
precipitation fields can help in determining aerosol transport.   The forecast satellite imagery conveys 
information about the atmosphere in 3 dimensions, providing information that would normally have to 
be gleaned from looking at maps of meteorological fields at many levels. 



 
Figure 16.  Screen capture of McIDAS-V display of a DBCRAS forecast grib2 time series from 
00UTC, 27 July 2007. 
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