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University of Puerto Rico at Mayagüez Direct Broadcast Polar Orbiter Workshop 
 
    27 April 2017   Lab 2 Part 1: Investigating MODIS and VIIRS SSTs 
 

Table 1: MODIS Band Number, Wavelength (µm), and Primary Application 
 
Reflective Bands       Emissive Bands 
1,2 0.645, 0.865  land/cld boundaries    20-23 3.750(2), 3.959, 4.050 sfc/cld temperature 
3,4 0.470, 0.555  land/cld properties    24,25 4.465, 4.515  atm temperature 
5-7 1.24, 1.64, 2.13 “       27,28 6.715, 7.325  water vapor 
8-10 0.415, 0.443, 0.490 ocean color/chlorophyll    29 8.55   sfc/cld temperature 
11-13 0.531, 0.565, 0.653 “      30 9.73   ozone 
14-16 0.681, 0.75, 0.865 “      31,32 11.03, 12.02  sfc/cld temperature 
17-19 0.905, 0.936, 0.940 atm water vapor     33-34 13.335, 13.635,   cld top properties  
26 1.375   cirrus clouds     35-36 13.935, 14.235  cld top properties 
 

Table 2: VIIRS Band Number, Wavelength (µm), and Primary Application 
 
Reflective Bands       Emissive Bands 
M (780 m FOV) 
1,2 0.412, 0.445  ocean color/aerosols  12 3.74  sfc/cld temperature 
3,4 0.488, 0.555  “    13 4.05  SST, fires 
5-7 0.672, 0.746, 0.865 “    14 8.55  cloud properties 
8 1.24   cloud particle size  15 10.8  SST, clouds 
9 1.38   thin cirrus   16 12.0  SST, moisture 
10 1.61   snow vs cloud    
11 2.25   cloud particle size 
 
I (390 m FOV) 
1 0.64   imagery    4 3.74  imagery clouds 
2 0.86   NDVI    5 11.5  cloud imagery 
3 1.61   snow map 
 

Table 3: Comparable VIIRS/MODIS Bands 
 

   MODIS    VIIRS-M 
8, 9  0.415, 0.443  1,2 ocean color 
10, 12   0.490, 0.565  3,4 “ 
14-16     0.681, 0.75, 0.865 5-7 “ 
5** 1.24   8 cld particle size 
26 1.38   9 thin cirrus 
6** 1.61   10 snow 
7** 2.13   11 cloud properties 
20    3.75   12 sfc/cld temp 
23 4.05   13 sfc temp 
29 8.55   14 sfc/cld temp 
31 11.0   15 sfc/cld temp 
32 12.0   16 sfc/cld temp 
 

       VIIRS-I 
1* 0.645   1 imagery 
2* 0.865   2 “ 
6** 1.64   3 “ 
20 3.75   4 “ 
31 11.0   5 “ 
* available at 250 m, ** available at 500 m resolution 
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Figure 1:  MODIS and VIIRS bandwidths plotted against standard atmosphere transmittance in the 
visible and near-infrared wavelengths (top) and black body radiance at terrestrial temperatures in 
infrared wavelengths (bottom). 
 
1.1.  Open Hydra, choose File from the Main HYDRA window, click on VIIRS directory and guide 
HYDRA to the directory containing S-NPP VIIRS data from 19 June 2014.  Select the directory and 
click on Choose.  Select the region shown in Figure 2 by holding down the left mouse button as you 
outline the region with the mouse, and then select M-Band 5 (.67 µm), and click on Display. 
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Figure 2:  VIIRS data Hydra screen capture from 19 June 2014, 19:04 UTC with a high resolution 
display of Band 5 (.67 µm) in the right panel. 
 
2.  Make a natural color image of this region by choosing Tools->RGB Composite from the main 
HYDRA window.  Highlight a color box from the RGBComposite window, and then choose a dataset 
band from the S-NPP VIIRS band list to insert.  Choose Red->M-Band 5 (.67 µm), Green->M-Band 4 
(.55 µm) and Blue->M-Band 3 (.48 µm).  Once the RGBComposite boxes are filled, select the Create 
button.  Your RGBComposite bands will be added to the bottom of the dataset list, under the 
Combinations heading.  Once it has been added, overlay the true color image in Window 1.  Enhance 
your RGB image by clicking on the rgb composite box in your image Window 1.  A window will open 
allowing you to change the range of each band that went into the composite.  Change the Gamma value 
in the bottom of the enhancement window to .4, and hit return.  Describe the patterns observed in the 
water. 
 
3.  Now investigate the region by overlaying the reflectances in Band 10 (1.6 µm) and the temperatures 
in Band 12 (3.7 µm) and Band 15 (10.7 µm).  Enhance the images to bring out features in the water.  
Briefly describe the features and their characteristics.  Where are the warmest and coldest temperatures 
over the water in Band 12 (3.7 µm) and Band 15 (10.7 µm)?  Why would the temperatures be different 
for these two infrared window channels?  How does the dark/bright region in the middle of the visible 
reflectance data match up with the temperatures in Band 12 (3.7 µm) data?  How about the visible 
bright spot in the middle – is it a cold or warm region in the infrared (3.7 µm)?  What is this 
dark/bright feature in the data? 
 
4.  Remove all of the overlays from your Window except for the true color and M-Band 5 image 
frames (Select the red circle with a “-“ in it to delete a display).  Now overlay the MODIS SST file 
from a similar Aqua overpass by clicking on File, click on File(s) and selecting 
a1.14170.1915.mod28.hdf.  The MODIS SST is a 1km product file, with the temperatures display in 
Degrees C.  It is not cloud cleared, so focus on the water by setting the enhancement boundaries. You 
can either left click+drag the green bars (grab the green boxes at the top) to change the lower or upper 
thresholds, or type them manually into the range boxes.  Change the lower threshold to 20 C and the 
upper threshold to 35 (See Figure 3). 
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Figure 3:  Aqua MODIS Sea Surface Temperature product image (left) and the data color scale and 
range for the Aqua pass from 19:15 UTC, 19 August 2014. 
 
5.  How does the warmest region in the SST image compare with the pattern you have identified in the 
VIIRS visible and infrared bands?  What is causing this region of warm ocean surface temperatures?  
Hint: Figure 4 is a Surface Analysis from 18 UTC, 19 June 2014. 
 

 
Figure 4:  NOAA NWS North American surface analysis from 18 UTC, 19 June 2014. 
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6.  How might this help you in quickly identifying sea state? 
 
7.  Examine other regions using the MODIS SST from this day.  Look at the high spatial resolution 
data around the Gulf coast states, around Cuba and the Yucatan Penisula.  What are the advantages and 
disadvantages of this polar data set when compared with other SST information available over the Gulf 
of Mexico and Atlantic waters?   Close HYDRA when you are done. 
 
Lab 2 Part 2: Investigating Tropical Storm Erika Using MODIS and VIIRS  
 
2.1 Open Hydra, click on File, and open File(s), and load the Terra MODIS 5 minute data segment 
from 28 August 2015 15:00 UTC (MOD021KM.A2015240.1500.006.2015241015635.hdf . Select the 
sub-region shown in Figure 1, and display Band 31 (11.0 µm) brightness temperatures at full spatial 
resolution.   Change the image enhancement from Inverse Gray to Rainbow and note the Range of 
temperatures across the scene. 

 
Figure 1:  Terra MODIS 5 minute granule observations from 28 August 2015, 15:00 UTC. 
 
2.  Now load Band 1 (.65 µm) and Band 6 (1.6 µm) into new individual windows. Make a quick scan 
by dragging the cursor and noting how and where these visible reflectance bands differ?  Where are the 
differences the greatest?  Use the Band 11 (11.0 µm) brightness temperatures to help you guess at what 
might be the cause of the largest reflectance differences.    
 
3. Create a scatter diagram between Band 1 (.65 µm) and Band 6 (1.6 µm) by selecting Tools->Scatter 
in the Band 1 image window and then Tools->Scatter in the Band 6 image window.   Click on the 
“points” button on the scatter diagram to switch to “density”, and draw a curve around the large 
protruding lobe of points, as shown in Figure 2.  Where do these points lie in the image?  Look at other 
features in the image and note where these lie in the scatter diagram. What features have low 
reflectivities in both bands?  High reflectivities?  How could you use these two bands to tell you 
something about cloud phase?  Why is that important?  
 
 



 6 

 
Figure 2:  Band 1 (.65 µm) (left panel) and Band 6 (1.6 µm) (center panel) reflectance images along 
with the scatter diagram created by plotting Band 6 versus Band 1 (right panel). 
 
4.  Now close the scatter diagram window and open the MODIS cloud product file from the same date 
and time (File-> File(s)-> MOD06_L2.A2015240.1500.006.2015241030627.hdf).  Choose 
Cloud_Phase_Infrared, and Overlay this field onto the Band 6 (1.6 µm) image.  The color coding for 
the Cloud Phase product is: 
 

Pink is Ice Cloud  
Blue is Water Cloud,   

 is possible Mixed Phase Cloud and  
Green is Undetermined. 

 
Toggle between the Cloud Phase and Band 6 (1.6 micron) image to see how the phase matches with 
the low and high reflectances in the clouds.  How well does the cloud phase MOD06 product 
discriminate ice/water cloud in this scene?  Where do you agree/disagree with it?  If you disagree, 
think of some reasons why it might seem to fail (can other bands help identify phase too)?. Do you 
think you could quickly determine cloud phase by looking solely at Band 6 (1.6 micron)?  What could 
this tell you about the maturity of a thunderstorm or complex of storms?  What are the limitations of 
using only Band 6 reflectances to determine cloud phase?  
 
5.  Now go back to the Band 31 (11.0 µm) data and note the location of the coldest clouds.  Display the 
Band 34 (13.7 µm) brightness temperatures into a new window.  Draw a transect through the coldest 
cloud tops in Band 31 (11.0 µm) as show in Figure 3 by selecting Tools->Transect and positioning the 
line by grabbing and moving the end points. Add the Band 34 (13.7 µm) brightness temperatures to the 
transect by selecting Tools->Transect in that image window. How do the brightness temperatures 
compare? Where are the temperatures similar and where are they different?  What is causing the 
differences?  Now display Band 35 (13.9 µm) and Band 36 (14.2 µm) in new windows, and add 
transects for both.  What is causing the difference in the temperatures away from the cold clouds?  
How could these bands be used to differentiate different types of clouds?  Close the transect window 
when you are finished. 
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Figure 3:  Terra MODIS Band 31 (11 micron) (left panel) and Band 34 (13.4 micron) (center panel)  
brightness temperature images and a transect of values through cold cloud and surrounding regions 
(right panel). 
 
Extra Credit – Continuing Cloud Investigation 
6.  Close the transect, Band 34 and Band 35 windows, and display the Band 26 (1.37 µm) reflectances 
in a new window (located in the band list after band 19).  Create a scatter diagram of Band 31 (11.0  
µm) brightness temperatures versus Band 26 (1.37 µm) reflectances (choose Tools->Scatter in both 
windows starting with Band 26).  Create a second scatter diagram of Band 36 (14.2 µm) brightness 
temperatures versus Band 26 (1.37 µm) reflectances.  Compare the two diagrams (see Figure 4). What 
is the major difference between the two? What do the slopes of the data points tell you about the 
relationship between these two bands? Compare the details in the clouds between the Band 26 (1.37 
µm) and Band 36 (14.2 µm) image. Are the clouds that are observed similar?  Which image is “crisper” 
(provides more detail, such as in the tops of the clouds)?  Discuss the pros and cons of using these two 
bands to look at high cloud. 
 

 
Figure 4:  Scatter diagram of Band 31 (11.0  µm) brightness temperatures versus Band 26 (1.37 µm) 
reflectances (left panel) and Band 36 (14.2 µm) brightness temperatures versus Band 26 (1.37 µm) 
reflectances (right panel) from the 28 August 2015 Terra MODIS data set.   
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Lab 2 Part 3: Investigating the Potential for Severe Weather using MODIS and VIIRS 
 
3.1  Overshooting cloud Tops (OTs) are convective cloud tops that have broken through into the lower 
stratosphere as a result of a strong updraft. Convective storms with OTs have the potential to produce 
severe weather at the ground (heavy rain, damaging winds, hail and tornadoes) as well as aviation 
hazards including lightning and turbulence.  Can you identify any cold protruding tops in our MODIS 
scene from 28 August 2015, Tropical Storm Erika?  Where are the coldest protrusions located?  
 
2.  Dr. Kris Bedka et al., published a paper outlining a technique to identify these OTs using 11 micron 
window channel brightness temperatures (MODIS Band 31).  This technique is described in detail in:  
 
K.M. Bedka, J.C. Brunner, R. Dworak, W.F. Feltz, J. Otkin, T. Greenwald, 2010: “Objective satellite-
based overshooting top detection using infrared window channel brightness temperature gradient”. J. 
Appl. Meteorol. Climatol., 49, pp. 181–202. 
 
This algorithm has been adapted for MODIS data, and an OT product can be created as part of the 
Puerto Rico Antenna Direct Broadcast product suite in near-real time.  Open the MODIS OTs data file 
for the same date and time (File->File(s)-> geocatL2_OT.Terra.2015240.150000.hdf ->Open).  
Overlay the ot_overshooting_top_grid_magnitude [OT_grid_mag] field onto the 11 micron Band 31 
brightness temperatures (Window 1) (Note, the area within the green Main Hydra window box will 
look blank, but when you Display the data, it will be there). Change the enhancement on the Band 31 
image to Inverse Gray and the overshooting top grid magnitude enhancement to Heat.   The technique 
attempts to distinguish the temperature of the OTs from the surrounding anvil (cirrus cloud shield). Are 
the locations of the OTs the same as the coldest tops in the scene?  If not, can you think of reasons 
why?  
 
3. According to the study by Bedka et al. 2010, with the presence of an overshooting top there is a 25% 
or greater chance of experiencing turbulence within 25 km of the overshooting top center.  The OT 
software includes image generation that displays a red circle overlaid on a Band 31 (11.0  µm) 
brightness temperature image representing the area within a 25 km radius of the respective 
overshooting top center (Figure 5).  Overlay the MODIS Cloud_Top_Pressure product (part of the 
MOD06 Cloud product) from this date and time.  Use the Cloud Top Pressure along with the Skew-T 
diagram from a RAOB launched in San Juan at 12 UTC, 28 August 2015 (Figure 6) to estimate the 
flight level where the greatest turbulence may occur (the Cloud Top Pressure product displays the tops 
in units of HPa). 
 
Other severe weather signatures and dangers to aviation interests can be identified from patterns in the 
scene.  Find at least one more of these.  
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Figure 5:  Areal coverage of the turbulence risk surrounding the Overshooting Top identified by the  
MODIS OT algorithm for the 28 August 2015 data set. 
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Figure 6:  Skew-T thermodynamic diagram of a sounding launched from San Juan, PR on 12 UTC, 28 
August 2015. 
 
This study also found that with the presence of an overshooting top, there is a 35% chance or greater, 
50% chance or greater, 65% chance or greater, or 70% chance or greater of experiencing Cloud-to-
Ground (CG) lightning within 10 km of the overshooting top center depending on the brightness 
temperature of the overshooting top, respectively. The colder the overshooting top brightness 
temperature is, the greater the chance of CG lightning. These relationships are shown for our 28 
August 2015 MODIS scene in Figure 7, with each colored dot identifying the area within a 10 km 
radius of the overshooting top center. 
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Figure 7:  Areal coverage of the risk of Cloud-to-Ground lightning surrounding the Overshooting Top 
identified by the MODIS OT algorithm for the 28 August 2015 data set. 
 
Extra Credit – Continuing Cloud Investigation 
 
4.  Open the Aqua 18:05 UTC file from this day, and load the Band 31 (11.0 µm) brightness 
temperatures into a new window. It should choose the region we have been investigating.  Now choose 
the S-NPP VIIRS data pass from for this day 18:02 UTC, 19 June 2014 (File-> VIIRS directory-
>VIIRS), and overlay the VIIRS M-Band 15 (10.76 µm) on top of the MODIS Aqua Band 31 (11.0 
µm) imagery.  Make sure the enhancements are the same. Can you tell which data set was observed 
before the other?  Identify a couple of changes that occurred during this few minute difference?  What 
does that tell you about the importance of timeliness in the delivery of the products? Which 11 micron 
data set provides more detail in the tops of the clouds and why?   
 
5. How can polar satellite data observations provide information that is complementary to what the 
GOES data can provide for a scene like this one? 
 


