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Lab 1:  Introduction to MODIS data and the Hydra visualization tool         21 September 2011 
 
Exercise 1 - Using Hydra to investigate a MODIS scene 
 

Table: MODIS Channel Number, Wavelength (µm), and Primary Application 
Reflective Bands      Emissive Bands 
1,2 0.645, 0.865  land/cld boundaries  20-23 3.750(2), 3.959, 4.050 sfc/cld temperature 
3,4 0.470, 0.555  land/cld properties  24,25 4.465, 4.515  atm temperature 
5-7 1.24, 1.64, 2.13 “     27,28 6.715, 7.325  water vapor 
8-10 0.415, 0.443, 0.490 ocean color/chlorophyll  29 8.55   sfc/cld temperature 
11-13 0.531, 0.565, 0.653 “    30 9.73   ozone 
14-16 0.681, 0.75, 0.865 “    31,32 11.03, 12.02  sfc/cld temperature 
17-19 0.905, 0.936, 0.940 atm water vapor   33-34 13.335, 13.635,   cld top properties  
26 1.375   cirrus clouds   35-36 13.935, 14.235  cld top properties 
 
1a). Inspect the 5 minute MODIS granule that covers New Zealand and the surrounding water on 28 
August 2011, 02:40 UTC observed by MODIS using HYDRA (see the attached instruction sheet 
explaining how to run Hydra).  After starting up Hydra, the main window appears (Figure 1). To load a 
MODIS Level-1B 1KM file from disk, click on “Load -> Local Data” and select the file to be loaded 
(e.g., MYD021KM.A2011240.0240.005.2011240160921.hdf).  When the file is loaded, an image of 
the 11 µm radiances appears, as shown in Figure 2 (note the missing data over the date line.  That is an 
artifact of Hydra and not the data).  
 

 
Figure 1:  The HYDRA window. 
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Figure 2:  HYDRA window with a MODIS L1B 1KM file loaded. 

 
1b).  Get familiar with the command menu Settings.  Band 31 (11 µm) is automatically displayed at 
reduced resolution.  Try different black and white enhancements by adjusting the color range 
(Settings->Set Color Range).  Use the toolbar at the top to zoom in and zoom out and translate the 
image.  Reset the image (Home icon+click on image).  Display the image in color and try different 
color enhancements. 
 
1c).  Start the Multi-Channel Viewer.  Display the data at full resolution by selecting a subset of the 
data displayed in the Hydra window (right most icon in toolbar in the Hydra window).  The one 
kilometer resolution data will appear in the Multi-channel Viewer window (see Figure 3). Use the 
arrow icon at the bottom of the Multichannel Viewer window to examine values in the full resolution 
image. Now locate the minimum and maximum brightness temperature values in the image.  Table 1 
shows the functions of the Multi-Channel Viewer Toolbar.  Practice zooming in and out, translating 
the image, selecting a zoom region, and displaying data values on the image. 
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Table 1.  Multi-Channel Viewer Tool Bar functions. 

 
 
 

 
Figure 3:  One kilometer resolution data displayed in the Multi-Channel Viewer window. 
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1d).  Investigate the brightness temperatures and reflectances observed over the land, ocean and cloud 
scene in different wavelengths; make sure you look at bands 1 (0.65 µm), 2 (.86 µm), 26 (1.38 µm), 6 
(1.64 µm), 7 (2.1), 20 (3.8 µm), 27 (6.78 µm), 31 (11 µm) and 35 (13.9 µm). 
 
What are the cloud and clear sky characteristics in each of these spectral bands.   
 

• Which bands see the surface?   
• Which don’t?   
• Where are the clouds (how do you know?).   
• Why do some of the clouds look different between bands 1 and 7? 

 
1e).  Now select Linear Combinations from the Tools menu at the top of the Multi-Channel Viewer 
window.  A new window (Channel Combinations Tool) will open.  You can create combined channel 
images and scatter plots which can be used to investigate the scene and infer atmospheric and surface 
properties by selecting the channels and mathematical operations located at the bottom of the window.  
To select a channel, you can either type the wavelength into the equation boxes at the bottom or move 
the colored bars to the desired wavelength using the Grab tool (Arrow) on the main toolbar and 
holding down the right mouse button while located on the color bar. Once you have chosen a band, 
click on the Compute button. Create single band images of the following bands (select a single band by 
choosing a blank in the mathematical operations drop down menu), and change the color scale to gray 
for the visible bands (in the new windows: Settings->set color scale->Gray). 
 

• Band 1 (0.65 µm) 
• Band 2 (.86 µm) 
• Band 7 (2.13 µm) 
• Band 31 (11 µm) 

 
1f).  Map Band 2 (.86 µm) versus Band 1 (0.65 µm) and create a scatter diagram by selecting the 
YAxis button in the Band 2 combination window and the XAxis button in the Band 1 combination 
window.  Once you have chosen both X and Y buttons, the Scatter button in the main Channel 
Combinations Tool Window will become active. Click on the Scatter button to open a scatter plot 
window (an example is shown in Figure 4). Select different regions in the scatter plot window and look 
at the corresponding points in the channel combination window. How do the reflectances compare?  
Where are they different?  Where are they the same?  Why are they different? Now follow the same 
procedure for Band 7 (2.13 µm) versus Band 1  (0.65 µm), and Band 1 (0.65 µm) (visible band) 
(YAxis) versus Band 31 (11 µm) (infrared band) (XAxis).  
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Figure 4:  Scatter diagram using Band 1 (0.65 µm) (left panel) as the X-Axis, Band 2 (.86 µm) (center 
panel) as the Y-Axis and the resultant scatter diagram (right panel) using MODIS reflectance 
observations over New Zealand from 28 August 2011. 
 
1g).  Close the main Channel Combinations Tool Window.  It will close all of the windows associated 
with it.    
 
1h).  Now load the MODIS cloud mask product MYD35_L2.A2011240.0240.005.2011240161611.hdf.  
A new  MODIS Cloud Mask window will appear, and the 4 category clear confidence will be overlaid 
on the data in the Multi-Channel Viewer.  The “Clear” confidence category is transparent.  You can 
toggle the image off and on using the button at the bottom of the Cloud Mask window (you may have 
to resize the window to see it).  How does the mask perform on this scene? 
 
Exercise 2 – Investigating the spectral signature of vegetation and snow using MODIS and 
Hydra 
 
2a).  Now select the scene shown in Figure 5 in the main Hydra window to examine at full resolution. 
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Figure 5:  Reduced and full resolution sub-scene from MODIS data observations from 28 August 

2011. 
2b). Display Band 1 (.65 µm) in the Multi-Channel Viewer. Now open a new Multi-Channel Viewer 
from the main Hydra window (Start->Multi-Channel Viewer) and display Band 2 (.86 µm) 
reflectances (see Figure 6). Adjust the color range of the Band 1 image so that you can see features in 
the land (Settings->Set Color Range). 
 
2c). Create a Transect of the Band 2 (.86 µm) reflectances. In the Multi-Channel Viewer window that 
is displaying the Band 2 data, select Tools->Transect. Create a transect that cuts through the Mainland 
of New Zealand as shown in Figure 6 by holding down the Shift Key and the right mouse button while 
you drag the mouse over the image (shft+right+drag). Now overlay the values of band 1 (.65 µm) 
reflectances over the same transect by selecting Tools->Transect from the Multi-Channel Viewer that 
is displaying the band 1 data. 
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Figure 6: Transect covering a portion of the Aqua MODIS image from 28 August 2011, 02:40 UTC, 

over Southern New Zealand for Bands 1 (.65 µm) and 2 (.86 µm). 
 

2d). Examine the transect. Look closely at the patterns of values along the transect in both bands. How 
do the values compare between these two bands over the water, land and cloud or snow? You can 
move the transect by right clicking on the green square in the Transect window and dragging the 
square so that you can identify where the transect points are in the image. Can you think of reasons for 
the similarities and differences? Now close the transect window. 
 
2e). Create a Red, Green and Blue composite image using the Hydra Tools->rgb option in the Multi-
Channel Viewer. The default combination is Band 1 (.65 µm) for red, Band 4 (.56 µm) for green and 
Band 3 (.47 µm) for blue. Use these defaults to create the image by selecting the Compute button. Note 
the features in the image. Leave the RGB window open. 
 
2f). Use the Channel Combination Tool to create a color image of Normalized Difference Vegetation 
Index (NDVI) where, NDVI = [Band 2 (0.86µm) – Band 1 (0.65µm)] / [Band 2 (0.86µm) + Band 1 
(0.65µm)]. Change the color scale to color (Settings->set color scale->Color). Examine the image. 
What are the values over the clouds or snow? Why? What are the values over the water? Now limit the 
range of values displayed to only those above zero (Settings->Set Color Range). Can you discriminate 
regions with some vegetation from those with little (use your RGB image if you need to)? What are the 
NDVI values in regions without significant vegetation; what are they in vegetated regions? Now 
change the color scale back to Gray. 
 
2g). Use the Channel Combination Tool to create an image of Band 31 (11.0 µm). Create a scatter 
diagram of the NDVI that you created in exercise 2f on the Y-axis against Band 31 (11.0 µm) on the 
X-axis. Select different regions in the scatter plot window (see Figure 7) and look at the corresponding 
points in the linear combination windows. Is there a relationship between NDVI and band 31 
brightness temperatures? Use the RGB image that you created to help you identify different regions.  
Can topography affect this relationship? 
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Figure 7: NDVI image (left), and the scatter diagram of NDVI versus band 31 (right) over the 
Mainland of New Zealand and near waters. 
 
2h).  Close the scatter diagram and NDVI windows. Create a new image of the Normalized Difference 
Snow Index (NDSI) where, NDSI = [Band 4 (0.56µm) – Band 7 (2.1µm)] / [Band 4 (056 µm) + Band 7 
(2.13µm)]. Change the color scale to color (Settings->set color scale->Color). Examine the image. 
What are the values over the clouds or snow? Can you guess why? What are the values over the water?  
Over the clear land?  Now limit the range of values displayed to only those above 0.4 (Settings->Set 
Color Range) (.4 is the NDSI snow/no snow MODIS threshold).  What areas are highlighted by the 
colors other than blue?  How well does it identify the snow areas?  
 
2i). Create a scatter diagram of the NDSI versus Band 31.  Can you find thresholds for both NDSI and 
Band 31 brightness temperatures that can capture only the snow in the image?  Now create a single 
band image of Band 2 (0.86µm) reflectances using the Channel Combination Tool.  Create another 
scatter diagram of the NDSI versus Band 2 (0.86µm) (See Figure 8).  Why would this help to 
discriminate between the water and the snow?  What is your opinion of the use of a single threshold 
applied globally for the discrimination of environmental fields? 
 
2j).  Close the Combination Tool windows. 
 
2k).  Now overlay the MODIS cloud mask over the a band 2 image in the Multi-Channel Viewer 
(Main Hydra Window->Load-> Local Data:  MYD35_L2.A2011240.0240.005.2011240161611.hdf).  
Where does it appear to work well?  Where does it seem to fail?  Can you tell why?  Why is it 
important to know the strengths and weaknesses of the products you are using? 
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Figure 8: NSDI image (left), and the scatter diagram of NDVI versus Band 2 (right) over the Mainland 
of New Zealand and near waters. 
 
Exercise 3 – Using MODIS water vapor imagery to identify potential atmospheric turbulence. 
 
3a).  Select a larger region over the Southern Island of New Zealand in the main Hydra window and 
examine Band 27 (6.78µm) as shown in Figure 9.  Compare it to Band 31 (11.0 µm).  Now create a 
transect through the waves seen in the Band 27 (6.78µm) image as shown in Figure 9. Estimate the 
temperature difference between the cold and warm parts of the waves.  Why might this be important to 
know for aviation applications?  How could you determine the vertical level of the waves? 
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Figure 9:  Aqua MODIS data set from 28 August 2011 as displayed in the main Hydra window (upper 
left panel), full resolution 1 km image (right panel) and the transect of brightness temperatures from 
Band 27 (6.78µm) (lower left panel).   
 
 
 
 
 
 
Exercise 4 - Investigating the spectral signature of clouds using MODIS and Hydra  
 
4a).  Close the Multi-Channel Viewer and load a new data set into Hydra from Terra MODIS, 27 
August 2011, 02:25 UTC (MOD021KM.A2011239.0225.005.2011239093212.hdf) as shown in Figure 
10.  This data set covers the Philippines and Typhoon Nanmadol.  Select the region shown in Figure 10 
to examine at full resolution. 
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Figure 10:  Terra MODIS data segment showing the Philippines and Typhoon Nanmadol observed on 
27 August 2011, at 02:25 UTC. 
 
4b).  Examine the storm using the visible bands 1 (.65µm), 6 (1.64µm) and 26 (1.38 µm).  How do the 
reflectances differ over the clouds.  Estimate how many cloud layers there are and give reasons for 
your answers.  Which band provides the most information about the highest clouds?  Can you think of 
reasons why it would be important to be able to separate the upper level clouds from the lower level in 
a Typhoon?  What could improved resolution of a cold cloud top provide? 
 
4c).  Now look at the clouds in the thermal bands 20 (3.80µm) and 31 (11.0µm) (you might want to 
display them in different Multi-Channel Viewers). Find warm and cold clouds in the band 31 data and 
compare to those in band 20. Why are they so different?  How could this information be useful?  
 
4d).  Now overlay the MODIS cloud product on your scene (Hyrda->Load->Local Data-> 
MOD06_L2.A2011239.0225.051.2011239112209.hdf).  When you do this the MODIS cloud phase 
product appears.  You can toggle the product off and on using the button at the bottom of the MOD06 
Level 2 Product Window (you may have to resize it).  Change the variable to Cloud Top Pressure in 
hPa.  Does it depict the cirrus outflow remaining at the same height as it expands outward?  How does 
this differ from what the Band 31 temperatures would tell you?  Why would this be useful to know? 
 
 
 



 12 

 
Figure 11:  Terra MODIS data through a thin slice of Typhoon Nanmadol observed on 27 August 
2011, at 02:25 UTC. 
 
4e). Now select the small slice of data shown in Figure 11. Create an image of the band 29 (8.50 µm) – 
band 31 (11.0 µm) brightness temperature differences using the Linear Combinations tool. Create a 
single band image of band 31 (11.0 µm) brightness temperatures using the Linear Combinations tool. 
Using these two images, create a scatter diagram of the band 29 – band 31 brightness temperature 
differences on the Y-Axis and the band 31 brightness temperatures on the X-Axis. Is there a pattern in 
the data? What is the range of values (max to min difference) in the band 29 (8.50 µm) – band 31 (11.0 
µm) brightness temperature differences? Where do the largest differences occur? Can you think of a 
reason why? 
 
4g). The MODIS cloud phase algorithm uses a simple set of thresholds to determine if a cloud is 
composed of ice:  
 

• Band 31 (11.0 µm) brightness temperature < 238 K or (band 29 (8.50 µm) – band 31) 
difference > .5 K.   

 
Why was a threshold of 238K chosen?  Apply these thresholds to your data in the scatter diagram. If 
you click in the scatter diagram window using the center mouse button, it will show you the X and Y 
values so you know where to start to draw your box. See Figure 12.   
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Figure 12: Image of the brightness temperature differences between bands 29 (8.50 µm) and band 31 
(11.0 µm), (left panel), an image of the band 31 brightness temperatures (center panel), and the scatter 
diagram of bands 29 -band 31 brightness temperature differences versus the band 31 brightness 
temperature differences (right panel) for the same scene as Figure 11. The images have the thresholds 
described in exercise 3g) applied. 
 
Do the thresholds work well for this cloud scene? Does it miss any of the cloud? 
 
4h). Close the Linear Combinations window. In the main Hydra window load in the MODIS cloud 
product file from the same date and time (MOD06_L2.A2011239.0225.051.2011239112209.hdf). This 
will open a new MOD06 Level 2 Products file window, and overlay the cloud phase product over the 
image in the Multi-Channel Viewer. How does the result compare with your results from exercise 3g?  
What are the advantages and disadvantages of using a straight threshold product and examining the 
data yourself in a real time setting?  
 
4i).  Go the kml directory for this lab directory, and click on the 2011239.terra.kml file.  This should 
launch the free version of the Google Earth Geobrowser.  Practice zooming in and out of the storm 
using the navigation tools in the upper portion of the display, or by scrolling up or down in the image.  
This output is a standard product of the IMAPP MODIS DB Google Earth (DBGE) package.  Can you 
identify the exactly location of the eye of the storm?  How could these true color high resolution 
MODIS products be useful in warning the public about the Typhoon hazards? 
 
 
 


